<div dir="ltr">Hi all,<div><br></div><div>I have a problem with recording the screen while being connected to a Kubuntu-based machine with x2go (a FreeNX-like SSH-based remote desktop).</div><div><br></div><div>--------------------------------------------------------------------------------------------------------------------------</div><div><div>login@baga:~$ avconv -f x11grab -r 25 -s 1600x900 -i :0.0 -vcodec libx264 -threads 4 output.avi</div><div>avconv version 9.18-6:9.18-0ubuntu0.14.04.1, Copyright (c) 2000-2014 the Libav developers</div><div>  built on Mar 16 2015 13:19:10 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)</div><div>[x11grab @ 0x2019080] device: :0.0 -> display: :0.0 x: 0 y: 0 width: 1600 height: 900</div><div>No protocol specified</div><div>[x11grab @ 0x2019080] Could not open X display.</div><div>:0.0: Input/output error</div><div>--------------------------------------------------------------------------------------------------------------------------<br></div><div><br></div><div>I tried to see where the display is redirected:</div><div><br></div><div>--------------------------------------------------------------------------------------------------------------------------<br></div><div><div>login@baga:~$ export</div><div>declare -x COLORFGBG="15;0"</div><div>declare -x DBUS_SESSION_BUS_ADDRESS="unix:abstract=/tmp/dbus-OqGNthJbd5,guid=9c28e918b5272419590701bc550ac912"</div><div>declare -x DISPLAY=":50"</div></div><div>--------------------------------------------------------------------------------------------------------------------------<br></div><div><br></div><div>So I tried the following:</div><div><br></div><div>--------------------------------------------------------------------------------------------------------------------------<br></div><div><div>login@baga:~$ avconv -f x11grab -r 25 -s 1600x900 -i :50 -vcodec libx264 -threads 4 output.avi</div><div>avconv version 9.18-6:9.18-0ubuntu0.14.04.1, Copyright (c) 2000-2014 the Libav developers</div><div>  built on Mar 16 2015 13:19:10 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)</div><div>[x11grab @ 0x1dc6080] device: :50 -> display: :50 x: 0 y: 0 width: 1600 height: 900</div><div>[x11grab @ 0x1dc6080] shared memory extension  found</div><div>Segmentation fault (core dumped)</div></div><div>--------------------------------------------------------------------------------------------------------------------------<br></div><div><br></div><div>My goal is to connect to a remote machine by x2go and to capture there (on the remote machine) recordings of the screen by a command-line tool. Actually, avconv is going to be executed by a Java application in a separate thread, while the min thread is going to do some other stuff on the screen.</div><div><br></div><div>Best,</div><div>Tomasz</div><div><br></div><div><br></div>-- <br><div class="gmail_signature"><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div><div dir="ltr"><div>Tomasz Bujlow, Ph.D.<br></div><div>Computer Network Researcher</div><div>Open-Source Software Developer</div><div><a href="mailto:tomasz@bujlow.com" target="_blank">tomasz@bujlow.com</a></div><div><a href="http://tomasz.bujlow.com" target="_blank">http://tomasz.bujlow.com</a></div><div><br></div></div></div></div></div></div></div></div></div>
</div></div>