[libav-tools] HandBrake compile on CentOS 7 throws error

Kurt Hermann hermann_kc at yahoo.com
Thu Dec 14 22:57:06 CET 2017


Tail of compiler output --
touch contrib/ffmpeg/.stamp.ffmpeg.patchset -e; /usr/bin/mkdir -p ./contrib/ffmpeg/libav-12.2/; cd ./contrib/ffmpeg/libav-12.2/; CC=/usr/bin/gcc CFLAGS="-I/opt/HandBrake/build/contrib/include -std=gnu99 -mfpmath=sse -msse2" CXX=/usr/bin/g++ CXXFLAGS="-I/opt/HandBrake/build/contrib/include -mfpmath=sse -msse2" CPPFLAGS="-I/opt/HandBrake/build/contrib/include -mfpmath=sse -msse2" LDFLAGS="-L/opt/HandBrake/build/contrib/lib " PKG_CONFIG_PATH="/opt/HandBrake/build/contrib/lib/pkgconfig" PATH="/opt/HandBrake/build/contrib/bin:/opt/HandBrake/build/contrib/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/sbin:/bin:/sbin:/home/kch/.local/bin:/home/kch/bin" ./configure --prefix=/opt/HandBrake/build/contrib/ --disable-shared --enable-static --enable-gpl --disable-doc --disable-bsfs --enable-bsf=aac_adtstoasc --disable-avconv --disable-avplay --disable-avprobe --disable-avdevice --disable-muxers --disable-network --disable-hwaccels --disable-vaapi --disable-vdpau --disable-encoders --enable-libmp3lame --enable-encoder=aac --enable-encoder=ac3 --enable-encoder=eac3 --enable-encoder=flac --enable-encoder=mpeg2video --enable-encoder=mpeg4 --enable-encoder=libmp3lame --enable-libopus --enable-encoder=libopus --enable-libvpx --enable-encoder=libvpx_vp8 --disable-decoder=libvpx_vp8 --enable-encoder=libvpx_vp9 --disable-decoder=libvpx_vp9 --enable-zlib --enable-bzlib --enable-pthreads --cc="/usr/bin/gcc" --extra-ldflags="-mfpmath=sse -msse2 -L/opt/HandBrake/build/contrib/lib" --enable-muxer=matroska --enable-muxer=webm --enable-muxer=mov --enable-muxer=mp4 --enable-muxer=psp --enable-muxer=ipod --disable-debug --extra-cflags="-mfpmath=sse -msse2 -I/opt/HandBrake/build/contrib/include -DNDEBUG"ERROR: opus not found
If you think configure made a mistake, make sure you are using the latestversion from Git.  If the latest version fails, report the problem to thelibav-tools at libav.org mailing list or IRC #libav on irc.freenode.net.Include the log file "config.log" produced by configure as this will helpsolving the problem.gmake: *** [contrib/ffmpeg/.stamp.ffmpeg.configure] Error 1[root at CENTOS7 build]# ^C[root at CENTOS7 build]# yum install opusLoaded plugins: fastestmirror, langpacksLoading mirror speeds from cached hostfile * base: mirror.wdc1.us.leaseweb.net * epel: kdeforge2.unl.edu * extras: mirror.wdc1.us.leaseweb.net * rpmfusion-free-updates: mirror.math.princeton.edu * rpmfusion-nonfree-updates: mirror.math.princeton.edu * updates: mirror.wdc1.us.leaseweb.netPackage opus-1.0.2-6.el7.x86_64 already installed and latest version
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-tools/attachments/20171214/21c1de2e/attachment.html>
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: config.verbose.txt
URL: <http://lists.libav.org/pipermail/libav-tools/attachments/20171214/21c1de2e/attachment.txt>


More information about the libav-tools mailing list