[libav-tools] VDPAU decoding failure

Luca Barbato lu_zero at gentoo.org
Thu Mar 12 11:04:49 CET 2015


On 12/03/15 09:26, Ulrich von Zadow wrote:
> Hi,
> 
> with the switch to libavcodec 56.1.0 (Ubuntu 14.10), our VDPAU
> decoder stopped working. Specifically, the call to
> 
> pCodec = avcodec_find_decoder_by_name("h264_vdpau”);
> 
> returns 0.
> 
> In the release notes to libav 10.5, I read "converted VDPAU to the
> hwaccel framework; the old way of using VDPAU is no longer
> supported”. Is this what we’re running into? 

Yes.

> If so, how big are the
> changes that are needed to get things running again? The code in
> question is on github:
> https://github.com/libavg/libavg/tree/master/src/video, mostly in the
> VDPAU* files.

You can look at

http://git.libav.org/?p=libav.git;a=blob;f=avconv_vdpau.c;h=1bd1f481906ce5aedb380f2c7fd2ca1941d1ca5f;hb=HEAD

this is more or less an example code how to use the current vdpau.

I hope it helps.

lu


More information about the libav-tools mailing list