[libav-tools] RTMP Encoding from /dev/video0

Luca Barbato lu_zero at gentoo.org
Wed Jul 15 00:26:35 CEST 2015


On 14/07/15 09:54, chris brisendine wrote:
> Can someone help me with the command line args, I need to send video
> from /dev/video0 to rtmp://foo.net/live/1234. I have tried "avconv -f
> video4linux2 -r 1 -i /dev/video0 -b:a 64k -vcodec libx264 -f flv
> "rtmp://foo.net/live/1234" I also have tried using raspivid from the
> rpi that streams raw h264 using a pipe "raspivid -w 640 -h 480 -t
> 1000000 -b 1000000 -fps 1 -g 5 -o - | ffmpeg -i - -vcodec copy -r 1 -g
> 5 -f flv " but are unable to get it to do anything to work I get this
> error also "HandShake: client signature does not match!"
>
> it needs to be in
> h.264 format with a bitrate less than 4000k
> Here is a screen shot of the settings
> http://ctv.ezuplink.com/wp-content/uploads/2015/04/stream1.png
>
> Any help would be greatly appreciated.

Which server are you using?

You seem to be using something that is not the normal libav rtmp 
implementation. Please compile the git version and report back.

lu



More information about the libav-tools mailing list