[libav-tools] Problem

Torsten Römer dode at luniks.net
Fri Dec 19 12:16:30 CET 2014


> All libs installed  but now i am facing that error on running mine 
> commands
>
> Unknown encoder 'libx264'
>  on command
>  sudo avconv -i state.mp4  -r 20 -s 480x352 -b 600k  -vcodec libx264 
> out_state.mp4
>
> Unknown encoder 'libmp3lame'
> on command
>  sudo avconv -i state.mp4  -r 20 -s 480x352 -b 600k  -vcodec libx264 
> out_state.mp4
>

Look at the output of "configure" for "libmp3lame enabled" and "libx264 
enabled", I guess both are "no" as they are by default.

You need to pass arguments to "configure" to enable them: "./configure 
--enable-gpl --enable-libx264 --enable-libmp3lame"

Torsten



More information about the libav-tools mailing list