[libav-tools] Fwd: avconv installation on CentOS 6.5

Zeeshan Akhter zeeshanakhter2009 at gmail.com
Fri Dec 19 07:02:52 CET 2014

here is the question :::

Best Regards!

*Zeeshan Akhter
Sr.Software Engineer(Oracle Java Certified)

*Website <http://latest-tutorial.com/>LinkedIn
<http://pk.linkedin.com/in/zeeshanakhter>Skype:  zeeshanakhter2009Mobile:

---------- Forwarded message ----------
From: Benedict Breuer <benedict.breuer at gmail.com>
Date: Fri, Dec 19, 2014 at 3:19 AM
Subject: [libav-tools] avconv resets sound level to zero.
To: libav-tools at libav.org

Hi list,

I'm currently trying to get deeper into video editing and cutting and
trying to get my videos from the camera into cinelerra. All is very
frustrating, because nothing works out of the box. Although I gained some
theoretical knowledge about formats, decoders, etc, I'm stuck with the
practical part. OK, enough said, hope you can help me with this avconv
problem or at least tell me if this is an av*-problem or I missed something:

I want to convert .mts files into dnxhd/pcm .MOV-files, but the sound is

The camcorder uses AVCHD so store the videos on an SD chip and I'm just
downloading the *.mts files from the STREAMS directory. When playing it
with totem, it has nice clean audio (side remark: Is the .mts-file enough,
or does avprobe work better with any of the other files?)

avprobe (within Ubuntu 14.04) identifies it as:

avprobe version 9.16-6:9.16-0ubuntu0.14.04.1, Copyright (c) 2007-2014 the
Libav developers
  built on Aug 10 2014 18:16:02 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
[mpegts @ 0x1902180] Non-increasing DTS in stream 2: packet 2 with DTS
39070, packet 3 with DTS 39070
Input #0, mpegts, from 'input.mts':
  Duration: 00:00:40.76, start: 0.500000, bitrate: 12840 kb/s
  Program 1
    Stream #0.0[0x1011]: Video: h264 (High), yuv420p, 1920x1080 [PAR 1:1
DAR 16:9], 50 fps, 50 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x1100]: Audio: ac3, 48000 Hz, stereo, fltp, 256 kb/s
    Stream #0.2[0x1200]: Subtitle: pgssub
[h264 @ 0x1907f00] Ignoring NAL unit 9 during extradata parsing
# avprobe output

I convert this file with avconv to:

avconv -i input.mts -vcodec dnxhd -b 185M -s 1920x1080 -aspect 16:9
-deinterlace -acodec pcm_s16be out_pcm_s16be.mov

Stream mapping:
  Stream #0:0 -> #0:0 (h264 -> dnxhd)
  Stream #0:1 -> #0:1 (ac3 -> pcm_s16be)

avprobe identifies this as:

avprobe version 9.16-6:9.16-0ubuntu0.14.04.1, Copyright (c) 2007-2014 the
Libav developers
  built on Aug 10 2014 18:16:02 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'out_pcm_s16be.mov':
    major_brand     : qt
    minor_version   : 512
    compatible_brands: qt
    encoder         : Lavf54.20.4
  Duration: 00:00:40.80, start: 0.000000, bitrate: 368360 kb/s
    Stream #0.0(eng): Video: dnxhd, yuv422p, 1920x1080, 367001 kb/s, 50
fps, 50 tbr, 50 tbn
    Stream #0.1(eng): Audio: pcm_s16be, 48000 Hz, 2 channels, s16, 1536 kb/s
# avprobe output

So far, so good. But when I now play that video with totem, there is no
sound at all!
Furthermore, when I import that file into cinelerra, it seams to have 3
audio tracks, but all are based at 0 dB, the audio line is always on the

Is this an error in avconv? Or am I doing anything wrong? Do I have to map
any channels? I couldn't find anything about that problem on the net.

I also tried to use little endian, I also tried pcm_u8, still the same.
Only mp3 as output works, either as video+mp3 in .mov or mp3 only:

avconv -i input.mts -vcodec dnxhd -b 185M -s 1920x1080 -aspect 16:9
-deinterlace -acodec mp3 out_mp3.mov
avconv -i input.mts -vn  acodec mp3 out_mp3.mov

(If this is not solvable, is there any other recommended audio input for
cinelerra (OK, not the best fitting mailing list for this question)?)

Thank you for any hints,


libav-tools mailing list
libav-tools at libav.org
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-tools/attachments/20141219/ceed2e4e/attachment.html>

More information about the libav-tools mailing list