[libav-tools] AVCONV -filter_complex option unrecognized.

Miscell smith misc.info99 at yahoo.com
Mon Sep 30 18:01:00 CEST 2013


--------------------------------------------
On Wed, 9/18/13, Luca Barbato <lu_zero at gentoo.org> wrote:

 Subject: Re: [libav-tools] AVCONV -filter_complex option unrecognized.
 To: libav-tools at libav.org
 Date: Wednesday, September 18, 2013, 6:44 AM
 
 On 18/09/13 00:54, Keith Lawson
 wrote:
 > On 2013-09-17 14:25, Miscell smith wrote:
 > 
 >> Keith,
 >>
 >> I'm afraid that -vf instead of -filter_complex did
 not work. I think
 >> the -vf option works only with a simple chain of
 filters, not a full
 >> filtergraph with multiple inputs and outputs. The
 error message I got was
 >>
 >> Output pad "default" for the filter "src" of type
 "buffer" not
 >> connected to any destination.
 >> Error opening filters!
 >>
 >> The -filter_complex command I have been using with
 avconv would work
 >> with ffmpeg, so I suspect it is simply that this
 option is not
 >> implemented in the version I am using (but which
 version would?).
 > 
 > I'm not a libav developer so I can't speak about
 -filter_complex and
 > when it was removed from avconv but it certainly
 doesn't appear to be
 > there any more. I can confirm that -vf works for
 complex filters with
 > avconv though as I use them to split video streams and
 combine them again.
 
 Which version of libav are you using?
 
 Libav 9 Implements filter complex, Libav 0.8 does not.
 
 lu

Thanks to lu and Keith for helping on this.  The Debian package used Libav 0.8, so I guess
I need to upgrade to Libav 9.

Ruth
 
 _______________________________________________
 libav-tools mailing list
 libav-tools at libav.org
 https://lists.libav.org/mailman/listinfo/libav-tools
 


More information about the libav-tools mailing list