[libav-tools] AVCONV -filter_complex option unrecognized.

Keith Lawson keith.lawson at libertas-tech.com
Wed Sep 18 00:54:11 CEST 2013


On 2013-09-17 14:25, Miscell smith wrote:

> Keith,
> 
> I'm afraid that -vf instead of -filter_complex did not work. I think 
> the -vf option works only with a simple chain of filters, not a full 
> filtergraph with multiple inputs and outputs. The error message I got 
> was
> 
> Output pad "default" for the filter "src" of type "buffer" not 
> connected to any destination.
> Error opening filters!
> 
> The -filter_complex command I have been using with avconv would work 
> with ffmpeg, so I suspect it is simply that this option is not 
> implemented in the version I am using (but which version would?).

I'm not a libav developer so I can't speak about -filter_complex and 
when it was removed from avconv but it certainly doesn't appear to be 
there any more. I can confirm that -vf works for complex filters with 
avconv though as I use them to split video streams and combine them 
again.

The error you're getting is because of a problem with your filter, not 
the switch. The filter is being parsed now but I think you're getting 
the "not connected to any destination" because you haven't defined any 
outputs for your input filters. The syntax should be:

[in_link_1]...[in_link_N]filter_name=arguments[out_link_1]...[out_link_M]

In your command I see [0] and [1] for in_links but no matching 
out_links.

What exactly are you trying to accomplish? I may be able to help you 
figure out the filter syntax. Once you get that right it should work, 
avconv definitely supports it.


> 
> Ruth
> 
> --------------------------------------------
> On Sun, 9/15/13, Keith Lawson <keith.lawson at libertas-tech.com> wrote:
> 
> Subject: Re: [libav-tools] AVCONV -filter_complex option unrecognized.
> To: libav-tools at libav.org
> Date: Sunday, September 15, 2013, 8:31 AM
> 
> On 2013-09-15 05:12, Miscell smith
> wrote:
> 
>> I'm trying to use AVCONV -filter_complex option as
> shown below but get an unrecognized option error. Please
> would you tell me which versions implement this feature? I
> am currently using standard Debian packages (from Jessie).
>> 
>> avconv -i %04d.jpg -i scale%04d.png -filter_complex
> [0][1]overlay=791:1050
>> -vcodec libx264 -profile:v high -r 25 -an test.avi
>> 
>> avconv version 0.8.7-6:0.8.7-1, Copyright (c) 2000-2013
> the Libav developers
>> built on May 20 2013 12:25:19 with gcc 4.7.3
>> Input #0, image2, from '%04d.jpg':
>> Duration: 00:00:07.04, start: 0.000000, bitrate: N/A
>> Stream #0.0: Video: mjpeg, yuvj440p, 1920x1080 [PAR
> 72:72 DAR 16:9],
>> 25 fps, 25 tbr, 25 tbn, 25 tbc
>> Input #1, image2, from 'scale%04d.png':
>> Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
>> Stream #1.0: Video: png, bgra, 338x30, 25 tbr, 25 tbn,
> 25 tbc
>> Unrecognized option 'filter_complex'
>> Failed to set value '[0][1]overlay=791:1050' for option
> 'filter_complex'
>> 
> 
> I'm not sure about the -filter_complex switch but I'm able
> to use complex filters with avconv just using the -vf switch
> and passing the appropriate filtergraph parameters. The
> filtergraph documentation here really helped me figure it
> out:
> 
> https://libav.org/libavfilter.html#Filtergraph-description [1]
> 
> I'd try passing your filter with just "-vf".
> 
>> Thanks,
>> 
>> Ruth
>> _______________________________________________
>> libav-tools mailing list
>> libav-tools at libav.org
>> https://lists.libav.org/mailman/listinfo/libav-tools [2]
> [1]
> 
> Links:
> ------
> [1] https://lists.libav.org/mailman/listinfo/libav-tools [2]
> _______________________________________________
> libav-tools mailing list
> libav-tools at libav.org
> https://lists.libav.org/mailman/listinfo/libav-tools [2]



Links:
------
[1] https://libav.org/libavfilter.html#Filtergraph-description
[2] https://lists.libav.org/mailman/listinfo/libav-tools


More information about the libav-tools mailing list