[libav-tools] avprobe assertion failure question

Torsten Sadowski tsadowski at gmx.net
Sun Oct 20 22:58:14 CEST 2013


Hello,

I am trying to play a webcam stream (rtsp, h.264) over libav. The webcam seems to be rather buggy but works with vlc/live555. I need libav because I want to use zoneminder. I think I figured out rtsp but could someone tell me what goes wrong here:

rtsp://192.168.130.152:554/live/av0?user=admin\&passwd=admin
avprobe version 9.10, Copyright (c) 2007-2013 the Libav developers
  built on Oct 18 2013 23:23:24 with gcc 4.7 (Ubuntu/Linaro 4.7.3-1ubuntu1)
  configuration: --prefix=/home/user/libav/libav
  libavutil     52.  3. 0 / 52.  3. 0
  libavcodec    54. 35. 0 / 54. 35. 0
  libavformat   54. 20. 3 / 54. 20. 3
  libavdevice   53.  2. 0 / 53.  2. 0
  libavfilter    3.  3. 0 /  3.  3. 0
  libavresample  1.  0. 1 /  1.  0. 1
  libswscale     2.  1. 1 /  2.  1. 1
[rtsp @ 0x2d79a00] SDP:
v=0
o=- 3422425 782967157  IN IP4 192.168.130.152
s=live
c=IN IP4 0.0.0.0
t=0 0
a=control:*
m=audio 0 RTP/AVP 8
a=control:rtsp://192.168.130.152:554/audio0
m=video 0 RTP/AVP 96
b=AS:2058
a=rtpmap:96 H264/90000
a=range:npt=0-
a=fmtp:96 profile-level-id=420028;packetization-mode=1;sprop-parameter-sets=Z0IAKOkAoAt3/gAAAwABxIAG3dAAzf5gDYgQlA==,aM4xUg==
a=control:rtsp://192.168.130.152:554/video0



avprobe: libavcodec/mpegvideo.c:1519: ff_MPV_frame_start: Assertion `s->pict_type == AV_PICTURE_TYPE_I || (s->last_picture_ptr && s->last_picture_ptr->f.data[0])' failed.
Core dumped

Cheers,
Torsten
-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/pkcs7-signature
Size: 1996 bytes
Desc: not available
URL: <http://lists.libav.org/pipermail/libav-tools/attachments/20131020/584890c4/attachment.bin>


More information about the libav-tools mailing list