[libav-tools] libmp3lame ignoring my sampling rates

Justin Ruggles justin.ruggles at gmail.com
Wed Feb 13 16:52:22 CET 2013


Hi,

On 02/12/2013 11:56 PM, Jacques Koorts wrote:
> The resulting file is playable.
> 
> The filesize is differs by about 12 bytes between 44K and 22K. The
> resulting file size is 1.5MB.
> I dont think its working correctly else why would lame show this error?

That message isn't from lame. It's from the mp3 muxer in libavformat.
The only thing that error means is that it isn't writing the Xing
header, which is not strictly required. Current Libav no longer has this
issue, as it now supports a Xing header for 22050Hz.

-Justin

See also:
http://git.libav.org/?p=libav.git;a=commitdiff;h=ca8e39dd0d2ed737bcf025236be9fdd1bd05cc4d;hp=6365e4db79cc1a8c2c153e73828e922962d1086e

> 
> On Tue, Feb 12, 2013 at 5:59 PM, Justin Ruggles
> <justin.ruggles at gmail.com <mailto:justin.ruggles at gmail.com>> wrote:
> 
>     On 02/12/2013 08:02 AM, Jacques Koorts wrote:
>     > Stream #0.0(und): Audio: libmp3lame, 22050 Hz, stereo, s16, 40 kb/s
> 
>     That doesn't look to me like it is ignoring it. Does the resulting file
>     play in various players?
> 
>     -Justin
> 
>     _______________________________________________
>     libav-tools mailing list
>     libav-tools at libav.org <mailto:libav-tools at libav.org>
>     https://lists.libav.org/mailman/listinfo/libav-tools
> 
> 
> 
> 
> _______________________________________________
> libav-tools mailing list
> libav-tools at libav.org
> https://lists.libav.org/mailman/listinfo/libav-tools



More information about the libav-tools mailing list