[libav-tools] need help defining audio stream inputs to avconv

Dave davestechshop at gmail.com
Wed Aug 28 09:06:04 CEST 2013


On Wed, Aug 28, 2013 at 2:40 AM, Luca Barbato <lu_zero at gentoo.org> wrote:

> On 28/08/13 08:29, Dave wrote:
> > see below
>
> Please just cut the text to the part of interest.
>

I'll blame this on changes to gmail's client. ;-) The new gmail web client
makes it more difficult to respond properly.



>
> > Based on your example, I tried this:
> >
> > OUTPUT="/path/audio_`date +%Y-%m-%d_%H%M`.flac"
> > avconv \
> > -ac 1 -f pulse -i
> > alsa_input.usb-Focusrite_Scarlett_2i2_USB-00-USB.analog-stereo \
> > -ac 1 -f pulse -i
>
> Still -ac 1 looks wrong.
>

I removed it. The issue is still not resolved.

>
> https://libav.org/avconv.html#amix
>
> Is what you need.
>

My build does not support that option. I'm on Ubuntu.
I'm reading this now:
http://superuser.com/questions/571147/how-do-i-recompile-libav-on-ubuntu-12-04-without-breaking-anything

It looks like the ubuntu version is compiled
wrong<http://askubuntu.com/questions/135682/avconv-x11grab-issues-unable-to-find-a-suitable-output-format-for-pulse#answer-136498>(yet
again)
>

I would prefer to find a PPA that has the latest binaries with the correct
compiler options.

I have to stop for the night but thanks for your help!
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-tools/attachments/20130828/e8007af1/attachment-0001.html>


More information about the libav-tools mailing list