[libav-tools] Missing frames when saving to PNG and then remuxing

Johannes Hezer j.hezer at studiorakete.de
Fri Aug 23 09:21:45 CEST 2013


I think you need to use -r 24 twice once before the image seq coming in 
and after for the container out..


Am 8/23/13 8:59 AM, schrieb FG:
> Hello. I'm having trouble producing a fluid motion picture with
> libavcodec and libx264, but let's stick to the command line for now,
> because the problems are visible there as well.
>
> I had a clip, exactly 1-minute-long, encoded with libx264 baseline
> at 24 FPS. Then I have issued the following commands:
>
>     avconv -i test.mp4 test_%04d.png
>     avconv -i test_%04d.png -an -c:v libx264 -r 24 glued.mp4
>     avconv -i glued.mp4 glued_%04d.png
>
> The playback of glued.mp4 isn't smooth and it's missing frames:
> There last test image is test_1440.png, as expected, but as for glued
> it's only glued_1382.png. 58 frames are missing throughout the movie.
>
> What am I doing wrong?
>
>
> cheers
> _______________________________________________
> libav-tools mailing list
> libav-tools at libav.org
> https://lists.libav.org/mailman/listinfo/libav-tools


-- 
STUDIO RAKETE GmbH
Johannes Hezer, Compositing TD
Schomburgstr. 120
D - 22767 Hamburg

j.hezer at studiorakete.de
Tel:+49 (0)40 - 380 375 69 - 0
Fax:+49 (0)40 - 380 375 69 - 99

------------------------------------------------------
Pflichtangaben laut Handelsgesetzbuch und GmbH-Gesetz:

STUDIO RAKETE GmbH
Schomburgstr. 120 D - 22767 Hamburg

www.studiorakete.de / info at studiorakete.de

Geschaeftsfuehrer: Jana Bohl / Hans-Martin Rickers

Die Gesellschaft ist eingetragen im Handelregister des
Amtsgerichts Hamburg unter der Nummer HR B 95660
USt.-ID Nr.: DE 245787817



More information about the libav-tools mailing list