[libav-tools] speex encoder

Emanuele Delzeri emanuele.delzeri at gmail.com
Tue Jun 26 18:03:14 CEST 2012


Hi Anton,
thank you for answer,
I've execute  ./configure script, with the option: "--enable-libspeex
--enable-encoder=libspeex"
Installing the packages and executing "ffmpeg -version", I see:
"D A libspeex speex"

Where can I found config.log file?

2012/6/26 Anton Khirnov <anton at khirnov.net>

>
> On Tue, 26 Jun 2012 10:36:54 +0200, Emanuele Delzeri <
> emanuele.delzeri at gmail.com> wrote:
> > Hi all,
> > this is my first post in libav-tools mailing list.
> > I'm working in a linux embedded audio project and I need to use speex
> > encoder thought libav.
> > I've build libav 0.7.6 using bitbake with the following options
> > ./configure --arch=arm --target-os=linux --enable-shared
> --enable-pthreads
> > --enable-gpl --enable-postproc --enable-nonfree --enable-avfilter
> > --cross-prefix=${TARGET_PREFIX} --prefix=${prefix} --enable-version3
> > --enable-libmp3lame --enable-libtheora --enable-libvorbis
> --enable-libspeex
> > --enable-encoder=libspeex --enable-cross-compile
> > --extra-cflags="${TARGET_CFLAGS} ${HOST_CC_ARCH} ${TOOLCHAIN_OPTIONS}"
> > --extra-ldflags="${EXTRA_LDFLAGS}" --sysroot="${STAGING_DIR_TARGET}"
> > --enable-hardcoded-tables --cpu=cortex-a8
> >
> > After installing the packages(libav, libavcodec53, libavdevice53,
> > libavfilter2, libavformat53, libavutil51, libswscale2, libpostproc52 and
> > speex) ffmpeg gives me available speex codec only with decoding support
> > enable and not in encoding.
> >
>
> Are you sure you're using the correct encoder name? It's 'libspeex', not
> 'speex'.
>
> If yes, than can you attach your config.log?
>
> --
> Anton Khirnov
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-tools/attachments/20120626/8c8dfafe/attachment.html>


More information about the libav-tools mailing list