[libav-tools] streaming webm video

Israel Aguilar socomate at yahoo.es
Thu Jun 14 17:23:39 CEST 2012


Hi there

  I'm want to do something basic and simple just stream some video over 
http using webm format, and lately using html5 features to play video, 
so I've configured avserver:

Port 8090
BindAddress 0.0.0.0
MaxHTTPConnections 2000
MaxClients 1000
MaxBandwidth 10000
CustomLog -
NoDaemon

<Feed feed1.ffm>
File /tmp/feed1.ffm
FileMaxSize 100M
ACL allow 127.0.0.1
</Feed>

<Stream live.webm>
Feed feed1.ffm
Format webm
NoAudio
VideoCodec libvpx
VideoSize vga
VideoFrameRate 25
AVOptionVideo flags +global_header
PreRoll 15
StartSendOnKey
VideoBitRate 400
</Stream>

<Stream stat.html>
Format status
# Only allow local people to get the status
ACL allow localhost
ACL allow 192.168.0.0 192.168.255.255
</Stream>

# Redirect index.html to the appropriate site
<Redirect index.html>
URL http://192.168.1.185/
</Redirect>


After I run de avserver with:
      avserver -f /etc/avserver.conf -d &   #(to get some debug info)
and run avconv to stream video
     avconv -f video4linux2 -i /dev/video0 http://localhost:8090/feed1.ffm

the next is to retrieve the video from a browser, the url looks like: 
http://IP:8090/live.webm

Everything start to work but I get some system messages from avserver
     Thu Jun 14 17:17:26 2012 192.168.1.123 - - [GET] "/live.webm 
HTTP/1.1" 200 63
     Thu Jun 14 17:17:26 2012 192.168.1.123 - - New connection: GET 
/live.webm
     Thu Jun 14 17:17:26 2012 Codec for stream 0 does not use global 
headers but container format requires global headers
     Thu Jun 14 17:17:26 2012 Only VP8 video and Vorbis audio are 
supported for WebM.
     Thu Jun 14 17:17:26 2012 Error writing output header
and in the browser after some time at body contents put /video is 
corrupt/. I though with option "AVOptionVideo flags +global_header" 
global headers should be fix... but not.

Maybe this is not important but if I do:
avconv -f video4linux2 -i /dev/video0 video.webm
file video.webm goes well and I can replay it easily

some aditional info
uname -a: Linux cctv 3.2.0-23-generic-pae #36-Ubuntu SMP Tue Apr 10 
22:19:09 UTC 2012 i686 i686 i386 GNU/Linux

v4l-info: ### v4l2 device info [/dev/video0] ###
general info
     VIDIOC_QUERYCAP
     driver                  : "bttv"
     card                    : "BT878 video (ProVideo PV143)"
     bus_info                : "PCI:0000:05:01.0"
     version                 : 3.2.14
     capabilities            : 0x5000015 
[VIDEO_CAPTURE,VIDEO_OVERLAY,VBI_CAPTURE,READWRITE,STREAMING]


¿Could someone offer for help?





-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-tools/attachments/20120614/61fdd08c/attachment.html>


More information about the libav-tools mailing list