[libav-devel] [PATCH 16/20] tests: Move do_lavf() to fate-run.sh

Vittorio Giovara vittorio.giovara at gmail.com
Fri Sep 21 20:02:02 CEST 2018


On Fri, Sep 21, 2018 at 7:06 PM, Diego Biurrun <diego at biurrun.de> wrote:

> On Fri, Sep 21, 2018 at 05:28:01PM +0200, Vittorio Giovara wrote:
> > On Fri, Sep 21, 2018 at 2:56 PM, Diego Biurrun <diego at biurrun.de> wrote:
> > > On Thu, Sep 20, 2018 at 01:39:20PM +0200, Vittorio Giovara wrote:
> > > > On Thu, Sep 20, 2018 at 10:47 AM, Diego Biurrun <diego at biurrun.de>
> > > wrote:
> > > > > --- a/tests/fate-run.sh
> > > > > +++ b/tests/fate-run.sh
> > > > > -FATE_LAVF-$(call ENCDEC2, MPEG4,      MP2,       NUT)
> > > += nut
> > > > >  FATE_LAVF-$(call ENCMUX,  RV10 AC3_FIXED,        RM)
> > >  += rm
> > > > > -FATE_LAVF-$(call ENCDEC,  FLV,                   SWF)
> > > += swf
> > > > > -FATE_LAVF-$(call ENCDEC2, MPEG2VIDEO, MP2,       MPEGTS)
> > >  += ts
> > > > >  FATE_LAVF-$(CONFIG_YUV4MPEGPIPE_MUXER)
> > >  += y4m
> > > > >
> > > > > +
> > > > > +FATE_LAVF_LAVF-$(call ENCDEC2, MSMPEG4V3,  MP2,       ASF)
> > > > > += asf
> > > >
> > > > LAVF_LAVF? :-/
> > > > isn't there a way to prevent this duplication?
> > >
> > > Admittedly, this is not pretty. I'd have to rename the testing
> function as
> > > well, the Make variables match the testing function names. Suggestions?
> >
> > IMO renaming as you propose is fine
>
> I did not propose anything, I am waiting for suggestions ;-)
>
>

> I'd have to rename the testing function as
> well, the Make variables match the testing function names.
>

That sounded like a proposal :-p
-- 
Vittorio


More information about the libav-devel mailing list