[libav-devel] Help with patch identification

Andrey Voropaev voropaev.andrey at gmail.com
Wed Jan 31 16:04:13 CET 2018


Hello all!

I have rather unusual request. There's one video file that causes
segfault when played with libavcodec54 under Ubuntu (full version
6:9.20-0ubuntu0.14.04.1). The same file plays OK with newer versions
of libavcodec, in particular with libavcodec57 (full version
7:3.4.1-1).

I can't upgrade version of libavcodec in my version of Ubuntu, but I
thought I could try to apply patch that fixes the problem. There is
only one small obstacle, I don't know which patch is that :) So, I'm
coming here in hope that someone can identify the problem that happens
and then point me to some patch(es) in git that fix this.

The file that causes segfault can be found at
https://drive.google.com/open?id=16w3AwVX7a1JEebuw2LAksED_0Oyvdtb5

Thank you for your help

Andrey Voropaev


More information about the libav-devel mailing list