[libav-devel] [PATCH] tls_mbedtls: Use non-deprecated header file

Luca Barbato lu_zero at gentoo.org
Wed Apr 25 18:28:10 CEST 2018


On 25/04/2018 12:51, Diego Biurrun wrote:
> /usr/include/mbedtls/net.h:29:2: warning: #warning "Deprecated header file: Superseded by mbedtls/net_sockets.h" [-Wcpp]
> ---
>  libavformat/tls_mbedtls.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
> 
> diff --git a/libavformat/tls_mbedtls.c b/libavformat/tls_mbedtls.c
> index 5e01af8162..6eba090402 100644
> --- a/libavformat/tls_mbedtls.c
> +++ b/libavformat/tls_mbedtls.c
> @@ -23,7 +23,7 @@
>  #include <mbedtls/config.h>
>  #include <mbedtls/ctr_drbg.h>
>  #include <mbedtls/entropy.h>
> -#include <mbedtls/net.h>
> +#include <mbedtls/net_sockets.h>
>  #include <mbedtls/platform.h>
>  #include <mbedtls/ssl.h>
>  #include <mbedtls/x509_crt.h>
> 

Ok, I wonder why my build did not trigger it...

lu


More information about the libav-devel mailing list