[libav-devel] [PATCH] des: Add missing include

Vittorio Giovara vittorio.giovara at gmail.com
Sun Aug 30 13:52:58 CEST 2015


On Sat, Aug 29, 2015 at 10:33 PM, Martin Storsjö <martin at martin.st> wrote:
> On Sat, 29 Aug 2015, Vittorio Giovara wrote:
>
>> ---
>> Related to
>>
>> In file included from libavutil/des.h.c:1:
>> /Users/GiovaraV/src/libav/libavutil/des.h:33:5: warning:
>>      'FF_API_CRYPTO_CONTEXT' is not defined, evaluates to 0 [-Wundef]
>> #if FF_API_CRYPTO_CONTEXT
>>          ^
>>
>> Vittorio
>>
>> libavutil/des.h | 1 +
>> 1 file changed, 1 insertion(+)
>>
>> diff --git a/libavutil/des.h b/libavutil/des.h
>> index 32c2c9a..351fce2 100644
>> --- a/libavutil/des.h
>> +++ b/libavutil/des.h
>> @@ -23,6 +23,7 @@
>> #define AVUTIL_DES_H
>>
>> #include <stdint.h>
>> +#include <version.h>
>>
>> /**
>>  * @defgroup lavu_des DES
>> --
>> 1.9.5 (Apple Git-50.3)
>
>
> Ok (although in this case, we should also remember to remove this include
> again once the deprecation is done).

Oh, right, I can add this include inside the FF_API define if that's ok.

-- 
Vittorio


More information about the libav-devel mailing list