[libav-devel] [PATCH] vc1: Split bits used in libavformat into a separate header

Luca Barbato lu_zero at gentoo.org
Thu Sep 4 14:58:05 CEST 2014


On 04/09/14 14:09, Diego Biurrun wrote:
> On Wed, Sep 03, 2014 at 08:55:56PM +0200, Luca Barbato wrote:
>> On 03/09/14 18:20, Diego Biurrun wrote:
>>> This reduces inter-library dependencies.
>>> ---
>>>
>>> I was annoyed by constant libavformat recompiles while I was making IDCT
>>> changes the other day.
>>>
>>> The header is poorly named; better suggestions welcome.
>>
>> Seems ok, and I'd call it vc1_parser.h
> 
> That doesn't seem like a good name to me, it is not related to the
> existing vc1_parser.c.

IISC all of it is used in movenc, so I guess vc1_common or vc1_utils is ok.

lu


More information about the libav-devel mailing list