[libav-devel] [PATCH] avcodec.h: include version.h before using version macro

Diego Biurrun diego at biurrun.de
Mon Nov 18 19:17:55 CET 2013


On 18.11.2013 08:03, Vittorio Giovara wrote:
> --- a/libavcodec/avcodec.h
> +++ b/libavcodec/avcodec.h
> @@ -36,15 +36,16 @@
>   #include "libavutil/dict.h"
>   #include "libavutil/frame.h"
>   #include "libavutil/log.h"
> -#if FF_API_FAST_MALLOC
> -// to provide fast_*alloc
> -#include "libavutil/mem.h"
> -#endif
>   #include "libavutil/pixfmt.h"
>   #include "libavutil/rational.h"
>
>   #include "version.h"
>
> +#if FF_API_FAST_MALLOC
> +// to provide fast_*alloc
> +#include "libavutil/mem.h"
> +#endif

Why doesn't libavutil/mem.h include the right version.h?

Diego


More information about the libav-devel mailing list