[libav-devel] [PATCH] lavc: update doxy to use nondeprecated API.

Diego Biurrun diego at biurrun.de
Sun Nov 20 19:08:45 CET 2011


On Sat, Nov 19, 2011 at 08:01:16PM +0100, Anton Khirnov wrote:
> 
> --- a/libavcodec/avcodec.h
> +++ b/libavcodec/avcodec.h
> @@ -3812,9 +3812,9 @@ int avcodec_open(AVCodecContext *avctx, AVCodec *codec);
>   *
> - * if (avcodec_open(context, codec, opts) < 0)
> + * if (avcodec_open2(context, codec, opts) < 0)

There are more instances of avcodec_open() referenced in the doxy of
avcodec.h, this does not look right.

Diego


More information about the libav-devel mailing list