[libav-commits] configure: set icc_version where it is needed

Mans Rullgard git at libav.org
Sat Jul 21 18:27:08 CEST 2012


Module: libav
Branch: master
Commit: 07e3f9af9fc0d21682ab248c3ece99228d57b09f

Author:    Mans Rullgard <mans at mansr.com>
Committer: Mans Rullgard <mans at mansr.com>
Date:      Wed Jul 18 20:40:38 2012 +0100

configure: set icc_version where it is needed

This variable is only used once, so setting it there is clearer.

Signed-off-by: Mans Rullgard <mans at mansr.com>

---

 configure |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/configure b/configure
index 6760c0e..9e65bc4 100755
--- a/configure
+++ b/configure
@@ -1974,7 +1974,6 @@ elif $cc -v 2>&1 | grep -qi ^gcc; then
 elif $cc --version 2>/dev/null | grep -q Intel; then
     cc_type=icc
     cc_ident=$($cc --version | head -n1)
-    icc_version=$($cc -dumpversion)
     CC_DEPFLAGS='-MMD'
     AS_DEPFLAGS='-MMD'
     speed_cflags='-O3'
@@ -3146,6 +3145,7 @@ if enabled icc; then
     # icc 11.0 and 11.1 work with ebp_available, but don't pass the test
     enable ebp_available
     if enabled x86_32; then
+        icc_version=$($cc -dumpversion)
         test ${icc_version%%.*} -ge 11 &&
             check_cflags -falign-stack=maintain-16-byte ||
             disable aligned_stack



More information about the libav-commits mailing list