<html>
    <head>
      <base href="https://bugzilla.libav.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:basic.master@gmx.de" title="Stefan Pöschel <basic.master@gmx.de>"> <span class="fn">Stefan Pöschel</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - configure fails to recognize static libmp3lame"
   href="https://bugzilla.libav.org/show_bug.cgi?id=1090">bug 1090</a>
          <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">Resolution</td>
           <td>UPSTREAM
           </td>
           <td>---
           </td>
         </tr>

         <tr>
           <td style="text-align:right;">Status</td>
           <td>RESOLVED
           </td>
           <td>REOPENED
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - configure fails to recognize static libmp3lame"
   href="https://bugzilla.libav.org/show_bug.cgi?id=1090#c4">Comment # 4</a>
              on <a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - configure fails to recognize static libmp3lame"
   href="https://bugzilla.libav.org/show_bug.cgi?id=1090">bug 1090</a>
              from <span class="vcard"><a class="email" href="mailto:basic.master@gmx.de" title="Stefan Pöschel <basic.master@gmx.de>"> <span class="fn">Stefan Pöschel</span></a>
</span></b>
        <pre>Sorry, but this is not an issue that has to be fixed by Lame:

(In reply to Sean McGovern from <a href="show_bug.cgi?id=1090#c3">comment #3</a>)
<span class="quote">> lame's configury should be testing for and adding -lm to the pkg-config file
> as necessary.</span >

Lame does not use pkg-config. Thus libav doesn't employ pkg-config to check for
Lame's presence.

Instead libav tries to compile a tiny C program that makes use of a function of
the Lame API, and links against Lame (which currently fails if only static Lame
version is available). These linker parameters are hardcoded in libav's
configure:

---
  enabled libmp3lame        && require "libmp3lame >= 3.98.3" lame/lame.h
lame_set_VBR_quality -lmp3lame
---

So they have to be fixed there.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are watching all bug changes.</li>
      </ul>
    </body>
</html>