<html>
    <head>
      <base href="https://bugzilla.libav.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:lu_zero@gentoo.org" title="lu_zero@gentoo.org <lu_zero@gentoo.org>"> <span class="fn">lu_zero@gentoo.org</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - sws_scale overwrite 2 bytes"
   href="https://bugzilla.libav.org/show_bug.cgi?id=817">bug 817</a>
          <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">CC</td>
           <td>
                
           </td>
           <td>lu_zero@gentoo.org
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - sws_scale overwrite 2 bytes"
   href="https://bugzilla.libav.org/show_bug.cgi?id=817#c1">Comment # 1</a>
              on <a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - sws_scale overwrite 2 bytes"
   href="https://bugzilla.libav.org/show_bug.cgi?id=817">bug 817</a>
              from <span class="vcard"><a class="email" href="mailto:lu_zero@gentoo.org" title="lu_zero@gentoo.org <lu_zero@gentoo.org>"> <span class="fn">lu_zero@gentoo.org</span></a>
</span></b>
        <pre>One of the problems I'm seeing with your code is that you are using malloc,
while swscale requires aligned memory to operate.

You can use av_image_alloc to directly allocate the right amount of memory for
the image and have the linesizes/strides computed at the same time.

I checked your code updated to use av_image_alloc and ASAN does not spot
errors.

Using av_image_alloc solves your issue?</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are watching all bug changes.</li>
      </ul>
    </body>
</html>