<html>
    <head>
      <base href="https://bugzilla.libav.org/" />
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - spdif encoder refuses to encapsulate MLP"
   href="https://bugzilla.libav.org/show_bug.cgi?id=821">821</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>spdif encoder refuses to encapsulate MLP
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>Libav
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>git HEAD
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>X86
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Linux
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>enhancement
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>---
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>libavformat
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>bugzilla@libav.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>davidm@davidmonro.net
          </td>
        </tr></table>
      <p>
        <div>
        <pre>Created <span class=""><a href="attachment.cgi?id=521" name="attach_521" title="Trivial patch to enable MLP encapsulation in SPDIF">attachment 521</a> <a href="attachment.cgi?id=521&action=edit" title="Trivial patch to enable MLP encapsulation in SPDIF">[details]</a></span>
Trivial patch to enable MLP encapsulation in SPDIF

The spdif encoder refuses to encapsulate MLP. MLP over HDMI has been in the
HDMI standard since v1.1, and as far as I can tell is exactly the same as for
Dolby TrueHD, including using the same IEC61937 data type code (which the
standard actually referes to "MAT" rather than TrueHD or MLP). I've attached a
trivial patch to enable this, and it certainly works fine on my receiver
(Marantz NR1605) using:

aplay -D hdmi:CARD=HDMI,DEV=0,AES0=6 -c8 -fs16_le -r192000 out.spdif</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are watching all bug changes.</li>
      </ul>
    </body>
</html>