<html>
    <head>
      <base href="https://bugzilla.libav.org/" />
    </head>
    <body><span class="vcard"><a class="email" href="mailto:volodya@Whengendarmesleeps.org" title="VolodyA! V Anarhist <volodya@Whengendarmesleeps.org>"> <span class="fn">VolodyA! V Anarhist</span></a>
</span> changed
              <a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - Crash after 'decode_slice_header error' and 'no frame!'"
   href="https://bugzilla.libav.org/show_bug.cgi?id=602">bug 602</a>
          <br>
             <table border="1" cellspacing="0" cellpadding="8">
          <tr>
            <th>What</th>
            <th>Removed</th>
            <th>Added</th>
          </tr>

         <tr>
           <td style="text-align:right;">Status</td>
           <td>RESOLVED
           </td>
           <td>REOPENED
           </td>
         </tr>

         <tr>
           <td style="text-align:right;">Resolution</td>
           <td>FIXED
           </td>
           <td>---
           </td>
         </tr></table>
      <p>
        <div>
            <b><a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - Crash after 'decode_slice_header error' and 'no frame!'"
   href="https://bugzilla.libav.org/show_bug.cgi?id=602#c4">Comment # 4</a>
              on <a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - Crash after 'decode_slice_header error' and 'no frame!'"
   href="https://bugzilla.libav.org/show_bug.cgi?id=602">bug 602</a>
              from <span class="vcard"><a class="email" href="mailto:volodya@Whengendarmesleeps.org" title="VolodyA! V Anarhist <volodya@Whengendarmesleeps.org>"> <span class="fn">VolodyA! V Anarhist</span></a>
</span></b>
        <pre>Updated to the GIT HEAD, it's even worse now:

$ avconv -ss 2 -i 00044.MTS -ss 0:00:10.765 -i out.ogv -filter_complex
'overlay=x=W-w-10:y=H-h-10' -ss 1 -t 0:17:51 -c:v libtheora -q:v 9 -c:a
libvorbis -q:a 3 edited.ogv
avconv version v12_dev0-498-g2e09359, Copyright (c) 2000-2014 the Libav
developers
  built on Dec  5 2014 09:32:02 with gcc 4.8 (Ubuntu 4.8.2-19ubuntu1)
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 2 with DTS 201652,
packet 3 with DTS 201652
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 5 with DTS 244852,
packet 6 with DTS 244852
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 6 with DTS 244852,
packet 7 with DTS 244852
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 7 with DTS 244852,
packet 8 with DTS 244852
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 10 with DTS 288052,
packet 11 with DTS 288052
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 11 with DTS 288052,
packet 12 with DTS 288052
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 12 with DTS 288052,
packet 13 with DTS 288052
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 15 with DTS 331252,
packet 16 with DTS 331252
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 16 with DTS 331252,
packet 17 with DTS 331252
[mpegts @ 0x1795260] Non-increasing DTS in stream 2: packet 17 with DTS 331252,
packet 18 with DTS 331252
00044.MTS: could not seek to position 4.306
Input #0, mpegts, from '00044.MTS':
  Duration: 00:17:55.66, start: 2.306356, bitrate: 25058 kb/s
  Program 1 
    Stream #0:0[0x1011]: Video: h264 (High) [HDPR / 0x52504448]
      yuv420p, 1920x1080 [PAR 1:1 DAR 16:9]
      50 fps, 90k tbn, 100 tbc
    Stream #0:1[0x1100]: Audio: ac3 [AC[45]3 / 0x332D4341]
      48000 Hz, stereo, fltp, 256 kb/s
    Stream #0:2[0x1200]: Data: [144][0][0][0] / 0x0090
[ogg @ 0x17b1d40] Multiple fisbone for the same stream is not implemented.
Update your Libav version to the newest one from Git. If the problem still
occurs, it means that your file has a feature which has not been implemented.
[ogg @ 0x17b1d40] max_analyze_duration 5000000 reached
Input #1, ogg, from 'out.ogv':
  Duration: 00:18:12.13, start: 0.000000, bitrate: 222 kb/s
    Stream #1:0: Data: [0][0][0][0] / 0x0000
    Stream #1:1: Video: theora
      yuv420p, 800x592 [PAR 1:1 DAR 50:37]
      3.92 fps, 15 tbn, 15 tbc
    Metadata:
      RECORDMYDESKTOP : 0.3.8.1
    Stream #1:2: Audio: vorbis
      22050 Hz, mono, fltp, 89 kb/s
[h264 @ 0x2dfc500] Ignoring NAL unit 6 during extradata parsing
    Last message repeated 2 times
Output #0, ogg, to 'edited.ogv':
  Metadata:
    encoder         : Lavf56.7.1
    Stream #0:0: Video: libtheora
      yuv420p, 1920x1080 [PAR 1:1 DAR 16:9], q=2-31, 200 kb/s
      50 fps, 90k tbn, 90k tbc
    Metadata:
      encoder         : Lavc56.6.0 libtheora
    Stream #0:1: Audio: libvorbis
      48000 Hz, stereo, fltp
    Metadata:
      encoder         : Lavc56.6.0 libvorbis
Stream mapping:
  Stream #0:0 (h264) -> overlay:main (graph 0)
  Stream #1:1 (theora) -> overlay:overlay (graph 0)
  overlay (graph 0) -> Stream #0:0 (libtheora)
  Stream #0:1 -> #0:1 (ac3 (native) -> vorbis (libvorbis))
Press ctrl-c to stop encoding
av_interleaved_write_frame(): Invalid argument


I have uploaded samples to the '<a class="bz_bug_link 
          bz_status_REOPENED "
   title="REOPENED - Crash after 'decode_slice_header error' and 'no frame!'"
   href="show_bug.cgi?id=602">bug602</a>' directory, out.ogv is uploaded as is,
00044.MTS has been cut with dd. Thanks for your time.</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are watching all bug changes.</li>
      </ul>
    </body>
</html>