<html>
    <head>
      <base href="https://bugzilla.libav.org/" />
    </head>
    <body><table border="1" cellspacing="0" cellpadding="8">
        <tr>
          <th>Bug ID</th>
          <td><a class="bz_bug_link 
          bz_status_NEW "
   title="NEW - decode_slice_header error in mp4"
   href="https://bugzilla.libav.org/show_bug.cgi?id=783">783</a>
          </td>
        </tr>

        <tr>
          <th>Summary</th>
          <td>decode_slice_header error in mp4
          </td>
        </tr>

        <tr>
          <th>Product</th>
          <td>Libav
          </td>
        </tr>

        <tr>
          <th>Version</th>
          <td>9
          </td>
        </tr>

        <tr>
          <th>Hardware</th>
          <td>Other
          </td>
        </tr>

        <tr>
          <th>OS</th>
          <td>Linux
          </td>
        </tr>

        <tr>
          <th>Status</th>
          <td>NEW
          </td>
        </tr>

        <tr>
          <th>Severity</th>
          <td>normal
          </td>
        </tr>

        <tr>
          <th>Priority</th>
          <td>---
          </td>
        </tr>

        <tr>
          <th>Component</th>
          <td>general
          </td>
        </tr>

        <tr>
          <th>Assignee</th>
          <td>bugzilla@libav.org
          </td>
        </tr>

        <tr>
          <th>Reporter</th>
          <td>uznick@ya.ru
          </td>
        </tr></table>
      <p>
        <div>
        <pre>I convert mp4 source file using VLC command

/Applications/VLC.app/Contents/MacOS/VLC -I dummy
/home/uznick/H264_test5_voice_mp4_480x360.mp4 vlc://quit --sout
"#transcode{vb=5000,ab=160,vcodec=h264,height=1080,channels=2,width=1920,samplerate=48000,acodec=aac}:std{access=file{no-overwrite},mux=mp4,dst='/home/uznick/test.mp4'}"
 --sout-avcodec-strict=-2 -vvv

The file looks perfectly playable.

And then I try to convert it to FLV using: avconv -y -loglevel error -i
/home/uznick/test.mp4 -codec copy /home/uznick/test.mp4.flv

The response I get is and convertation stops:
[h264 @ 0x7fdd8a819a00] A non-intra slice in an IDR NAL unit.
[h264 @ 0x7fdd8a819a00] decode_slice_header error

And when I use avprobe to check the file, I get the same lines there:

avprobe version 11, Copyright (c) 2007-2014 the Libav developers
  built on Sep 14 2014 06:57:51 with Apple LLVM version 5.1 (clang-503.0.40)
(based on LLVM 3.4svn)
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x7f7fc1807800] multiple edit list entries, a/v
desync might occur, patch welcome
[h264 @ 0x7f7fc1806600] A non-intra slice in an IDR NAL unit.
[h264 @ 0x7f7fc1806600] decode_slice_header error
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from '/home/uznick/test.mp4':
  Metadata:
    major_brand     : isom
    minor_version   : 0
    compatible_brands: mp41avc1qt
    creation_time   : 2014-11-17 09:15:03
    encoder         : vlc 2.1.5 stream output
    encoder-eng     : vlc 2.1.5 stream output
  Duration: 00:00:04.86, start: 0.000000, bitrate: 1746 kb/s
    Stream #0.0(eng): Audio: aac, 44100 Hz, stereo, fltp, 126 kb/s (default)
    Metadata:
      creation_time   : 2014-11-17 09:15:03
    Stream #0.1(eng): Video: h264 (High), yuv420p, 640x360 [PAR 57:128 DAR
19:24], 1663 kb/s, 30 fps, 1000k tbn, 60 tbc (default)
    Metadata:
      creation_time   : 2014-11-17 09:15:03
# avprobe output</pre>
        </div>
      </p>
      <hr>
      <span>You are receiving this mail because:</span>
      
      <ul>
          <li>You are watching all bug changes.</li>
      </ul>
    </body>
</html>