[libav-bugs] [Bug 940] New: Last frames are dropped while decoding with h264_qsv decoder

bugzilla at libav.org bugzilla at libav.org
Wed Apr 13 15:42:25 CEST 2016


https://bugzilla.libav.org/show_bug.cgi?id=940

            Bug ID: 940
           Summary: Last frames are dropped while decoding with h264_qsv
                    decoder
           Product: Libav
           Version: git HEAD
          Hardware: X86
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: ---
         Component: libavcodec
          Assignee: bugzilla at libav.org
          Reporter: giri.lv414 at gmail.com

I tried to install MSS SDK on HSW system , right now i can able to triggered HW
accelerators (h264_qsv decoder),

I am trying to compare decoding outputs with qsv decoder and without qsv
decoder those two outputs are not matched..

commands used are as follows..

1) with qsv : ./ffmpeg -vcodec h264_qsv -r 30 -i input.264 -pix_fmt yuv420p
output_qsv.yuv

2) with out qsv : ./ffmpeg -i input.264 output_x264.yuv ( default decoder )

these 2 outputs are output_qsv.yuv and output_x264.yuv files are not matched..

I think that qsv decoding with different frame rate, that why i am using
command by putting " -r 30 " before i/p read,now getting 0th frames twice while
decoding with qsv ..but CPU utilization is very good while decoding..

I think that both decoders (with and with out qsv options....) should match
right..?

ffmpeg version -- ffmpeg-3.0.1 downloaded from
​https://www.ffmpeg.org/download.html

This is a latest one build from source repo only..

I have faced few issues like:

i) most of the sequences getting " 0 " th frame twice while decoding with
h264_qsv decoder,
ii) Last 4 to 5 frames is not dumped in to output file,
iii) few frames are also dropped into output file,
iv) as per my observation those 4 frames are appended with N-15 frames in the
output file, where N is the no of frames in a sequence
and few frames are also dropped..

please give reply as soon as possible, please let me know any information
needed..

-- 
You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-bugs/attachments/20160413/384503aa/attachment.html>


More information about the libav-bugs mailing list