[libav-bugs] [Bug 831] New: avconv does not indicate error on disk full

bugzilla at aruru.libav.org bugzilla at aruru.libav.org
Sun Mar 15 03:15:41 CET 2015


https://bugzilla.libav.org/show_bug.cgi?id=831

            Bug ID: 831
           Summary: avconv does not indicate error on disk full
           Product: Libav
           Version: 11
          Hardware: X86
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: ---
         Component: utilities
          Assignee: bugzilla at libav.org
          Reporter: andrew.moise at gmail.com

When I use avconv in a simple way and my disk fills up, there's no indication
that there's been an error:

$ avconv -i CAM00214.mp4 -vcodec copy -acodec copy disk-full.mp4 && echo worked
avconv version 11.2-6:11.2-1, Copyright (c) 2000-2014 the Libav developers
  built on Jan 17 2015 21:51:46 with gcc 4.9.2 (Debian 4.9.2-9)
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'CAM00214.mp4':

  (snip)

Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (copy)
Press ctrl-c to stop encoding
frame= 1441 fps=409 q=-1.0 Lsize=   20520kB time=49.42 bitrate=3401.4kbits/s    
video:58709kB audio:582kB other streams:0kB global headers:0kB muxing overhead:
unknown
worked
$ ls -l CAM00214.mp4 disk-full.mp4 
-rwxr-xr-x 1 moise moise 61119020 Mar 11 14:13 CAM00214.mp4
-rwxr-xr-x 1 moise moise 21012480 Mar 14 22:09 disk-full.mp4
$

Thanks in advance for your help.

-- 
You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-bugs/attachments/20150315/1752914c/attachment-0001.html>


More information about the libav-bugs mailing list