[libav-bugs] [Bug 819] New: compilation error in libavcodec/x86/fft.asm (nasm)

bugzilla at aruru.libav.org bugzilla at aruru.libav.org
Mon Feb 16 15:47:19 CET 2015


https://bugzilla.libav.org/show_bug.cgi?id=819

            Bug ID: 819
           Summary: compilation error in libavcodec/x86/fft.asm (nasm)
           Product: Libav
           Version: git HEAD
          Hardware: Other
                OS: Mac OS
            Status: NEW
          Severity: normal
          Priority: ---
         Component: libavcodec
          Assignee: bugzilla at libav.org
          Reporter: f.tomassetti at gmail.com

According to the wiki I ran:
brew install libav
./configure 

was complaining about missing yasm/nasm. I ran:

brew install nasm
./configure [ok this time]
make

I got:

YASM    libavcodec/x86/fft.o
libavcodec/x86/fft.asm:54: panic: section ".rodata" has already been specified
with alignment 32, conflicts with new alignment of 16
make: *** [libavcodec/x86/fft.o] Error 3


It could be related to:
https://lists.ffmpeg.org/pipermail/ffmpeg-cvslog/2012-April/049527.html

nasm -version
NASM version 0.98.40 (Apple Computer, Inc. build 11) compiled on Sep 18 2014

-- 
You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-bugs/attachments/20150216/f4614356/attachment-0001.html>


More information about the libav-bugs mailing list