[libav-bugs] [Bug 841] New: vp8 rtsp copy stream not working

bugzilla at aruru.libav.org bugzilla at aruru.libav.org
Fri Apr 10 17:46:21 CEST 2015


https://bugzilla.libav.org/show_bug.cgi?id=841

            Bug ID: 841
           Summary: vp8 rtsp copy stream not working
           Product: Libav
           Version: 11
          Hardware: X86
                OS: Windows
            Status: NEW
          Severity: normal
          Priority: ---
         Component: libavformat
          Assignee: bugzilla at libav.org
          Reporter: yv at 3cx.com

Created attachment 525
  --> https://bugzilla.libav.org/attachment.cgi?id=525&action=edit
webm receiver

I am trying to send and receive a webm file (only video) through a rtsp tcp
tunnel with the following command line, but the receiver part produces an empty
file:

Receiver site:
avconv -v 9 -loglevel 99 -y -f rtsp -rtsp_flags listen -rtsp_transport tcp -i
rtsp://127.0.0.1:23020/live.sdp -vcodec copy -an out.webm

Transmit site:
avconv -v 9 -loglevel 99 -i small.webm -vcodec copy -an -f rtsp -rtsp_transport
tcp rtsp://127.0.0.1:23020/live.sdp

The same, but with mp4 files, instead is (correctly) working.

Receiver site:
avconv -v 9 -loglevel 99 -y -f rtsp -rtsp_flags listen -rtsp_transport tcp -i
rtsp://127.0.0.1:23020/live.sdp -vcodec copy -an out.mp4

Transmit site:
avconv -v 9 -loglevel 99 -i small.mp4 -vcodec copy -an -f rtsp -rtsp_transport
tcp rtsp://127.0.0.1:23020/live.sdp

Please see the full logs and the media files in attachment
Thank you.

-- 
You are receiving this mail because:
You are watching all bug changes.
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.libav.org/pipermail/libav-bugs/attachments/20150410/474a3a2b/attachment-0001.html>


More information about the libav-bugs mailing list