[libav-bugs] [Bug 749] New: RTMP metadata does not contain framerate.

bugzilla at libav.org bugzilla at libav.org
Fri Sep 26 11:14:44 CEST 2014


https://bugzilla.libav.org/show_bug.cgi?id=749

           Summary: RTMP metadata does not contain framerate.
           Product: Libav
           Version: git HEAD
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: Normal
         Component: libavformat
        AssignedTo: bugzilla at libav.org
        ReportedBy: temp987654 at freemail.hu


Command line:
avconv -re -i univac.mp4 -acodec copy -vcodec copy -f flv \
    "rtmp://localhost:8081/publish/first;secret"

RTMP metadata:
[  
   @setDataFrame,
   onMetaData,
   {  
      audiocodecid=10.0,
      audiosamplerate=44100.0,
      width=640.0,
      videodatarate=439.5419921875,
      compatible_brands=isomiso2avc1mp41,
      videocodecid=7.0,
      major_brand=isom,
      filesize=0.0,
      title=Classic TV Commercial for a UNIVAC computer,
      duration=0.0,
      minor_version=512,
      height=480.0,
      audiodatarate=55.228515625,
      stereo=true,
      audiosamplesize=16.0,
      comment=license:http://creativecommons.org/licenses/publicdomain/,
      encoder=Lavf55.20.0
   }
]

AFAIK that information can not be calculated from any other pieces of data, so
this one clearly breaks RTMP output in general.

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list