[libav-bugs] [Bug 637] New: Apple Prores decoder image blocky and distorted

bugzilla at libav.org bugzilla at libav.org
Sun Feb 9 16:10:18 CET 2014


https://bugzilla.libav.org/show_bug.cgi?id=637

           Summary: Apple Prores decoder image blocky and distorted
           Product: Libav
           Version: git HEAD
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: Normal
         Component: libavcodec
        AssignedTo: bugzilla at libav.org
        ReportedBy: francois at postmasters.co.za


When using libav to convert apple prores video to MP4 or even to still JPG
images, the image gets a strange block-distortion.  I converted the same Prores
files to many different MP4 video sizes and JPG files and see the same
distortion on all of them - leading me to believe the problem lies with the
Apple Prores decoder in libav.  All source videos come from Apple Final Cut Pro
7 and plays perfectly in our edit suites - quicktime wrapper with Apple Prores
422 1920x1080i 25.

Please see attachment.  On the blue image, the background should be a smooth
blue gradient.  

This is another report of the same bug; The conclusion was:
On 12.10 recent ffplay and ffmpeg from FFmpeg decode it properly, but Libav
products (avplay and fake "ffplay") in the repo do not decode it properly.
Since it also works in QuickTime, but not in Libav stuff, I do not believe this
is a(n existing) FFmpeg bug.

http://ubuntuone.com/1127cqiP1JhJ98aMdziRBy

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list