[libav-bugs] [Bug 585] New: FFV1: Current implementation cannot handle pix_fmt: gbrp14

bugzilla at libav.org bugzilla at libav.org
Mon Nov 4 02:57:47 CET 2013


https://bugzilla.libav.org/show_bug.cgi?id=585

           Summary: FFV1: Current implementation cannot handle pix_fmt:
                    gbrp14
           Product: Libav
           Version: git HEAD
          Platform: All
        OS/Version: All
            Status: NEW
          Severity: enhancement
          Priority: Normal
         Component: libavcodec
        AssignedTo: bugzilla at libav.org
        ReportedBy: pb at das-werkstatt.com


FFV1 currently cannot handle pix_fmt gbrp16.
FFmpeg's implementation supports the highest RGB bit-depth of 14bits, using
gbrp14.

Avconv currently throws the following error:
"Unknown pixel format requested: bgrp14."

I guess, because only bgrp10 and bgrp16 are supported in avconv's current
implementation.

I'd like to add that it would be nice if FFV1 files from ffmpeg would be as
natively interoperable as possible with avonv :)


Steps to reproduce:

-----------
$ avconv -f image2 -i tests/lena.pnm -t 1 -an -c:v ffv1 -level 1 -strict
experimental -pix_fmt bgrp14 -v 9 -loglevel 99 delme.avi
-----------

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list