[libav-bugs] [Bug 329] When error found (avconv) return code is not = 1

bugzilla-daemon at aruru.libav.org bugzilla-daemon at aruru.libav.org
Thu Jun 6 05:34:22 CEST 2013


http://bugzilla.libav.org/show_bug.cgi?id=329

jcoffi at gmail.com changed:

           What    |Removed                     |Added
----------------------------------------------------------------------------
                 CC|                            |jcoffi at gmail.com
           Severity|enhancement                 |minor

--- Comment #10 from jcoffi at gmail.com 2013-06-06 05:34:22 CEST ---
How is returning consistent error codes like a compliance checking tool?

(In reply to comment #8)
> (In reply to comment #7)
> > This case was fixed, but here is another example where avconv gives return code
> > = 0.
> > 
> > [h264 @ 0000000004263880] number of reference frames (0+6) exceeds max (4;
> > probably corrupt input), discarding one
> > 
> > Could you please check all the other cases, because now I cannot trust return
> > code. I need to double check log every time to see if there is some other cases
> > when error is found, but exit code is not = 1.
> 
> "all other cases"? Do you have an idea how large libav codebase is and how much
> effort that would be? If not, look at the number of files in the libavcodec dir
> alone. Or just the size and complexity of the h.264 decoder.
> 
> Sorry, but I don't think there's anyone with time and motivation to go over all
> of libav to make it work like a compliance checking tool. Reclassifying to a
> feature request.

-- 
Configure bugmail: http://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list