[libav-bugs] [Bug 447] New: Compilation fails with missing references from dsputil_mmx! (seems related to "--disable-everything" + "--enable-runtime-cpudetect")

bugzilla-daemon at aruru.libav.org bugzilla-daemon at aruru.libav.org
Tue Feb 12 15:15:55 CET 2013


https://bugzilla.libav.org/show_bug.cgi?id=447

           Summary: Compilation fails with missing references from
                    dsputil_mmx! (seems related to "--disable-everything"
                    + "--enable-runtime-cpudetect")
           Product: Libav
           Version: git HEAD
          Platform: X86
        OS/Version: Windows
            Status: NEW
          Severity: critical
          Priority: Normal
         Component: libavcodec
        AssignedTo: bugzilla at libav.org
        ReportedBy: mulder2 at gmx.de


When trying to build a libav with the following configuration:

> ./configure --toolchain=msvc --disable-debug --disable-network \
> --disable-everything --enable-runtime-cpudetect \
> --enable-parser=ac3 --enable-parser=mlp \
> --enable-decoder=ac3 --enable-decoder=eac3 --enable-decoder=truehd \
> --enable-decoder=mlp --enable-decoder=aac --enable-decoder=dca \
> --enable-decoder=vorbis --enable-decoder=ape --enable-decoder=alac \
> --enable-decoder=flac

I get this error during Make:

> libavcodec/libavcodec.a(dsputil_mmx.o): In function `ff_avg_pixels16_mmxext':
> undefined reference to `ff_avg_pixels8_mmxext'

I think this is a bug/regression, because it still worked with latest Git
around late Jan 2013, but is broken now.

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list