[libav-bugs] [Bug 610] New: -map option not ffmpeg-compatible

bugzilla at libav.org bugzilla at libav.org
Wed Dec 18 22:30:00 CET 2013


https://bugzilla.libav.org/show_bug.cgi?id=610

           Summary: -map option not ffmpeg-compatible
           Product: Libav
           Version: 9
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: enhancement
          Priority: Normal
         Component: utilities
        AssignedTo: bugzilla at libav.org
        ReportedBy: scott at cartasoft.com


This report is relative to Debian's libav-tools 6:9.10-1, but I believe this
likely is a problem with upstream; hence this report.

avconv's -map specifier expects streams in the format <file>:<stream>.

Unfortunately, ffmpeg's -map uses <file>.<stream>. :-(

This means I cannot use avconv as a drop-in replacement for ffmpeg with
utilities (such as pyTivo) that generate -map options using ffmpeg syntax.

I have generated a private workaround by kludging pyTivo to convert "." to ":"
in its emitted ffmpeg [sic] commands, but it would be far preferable if avconv
used (or accepted) a period as a delimiter.

If, alternatively, you think it is not desirable to support "." as a stream
delimiter in -map specifications, then please change the output (i.e. from
"avconv -i myfile") so that it also uses ":" instead of "." (in which case
users such as pyTivo, which only feed back what they see, will work correctly).

Thanks,
Scott Bailey

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list