[libav-bugs] [Bug 601] New: Frame size option is discarded when using a video filter

bugzilla at libav.org bugzilla at libav.org
Mon Dec 2 13:10:20 CET 2013


https://bugzilla.libav.org/show_bug.cgi?id=601

           Summary: Frame size option is discarded when using a video
                    filter
           Product: Libav
           Version: 0.8
          Platform: All
        OS/Version: Linux
            Status: NEW
          Severity: normal
          Priority: Normal
         Component: general
        AssignedTo: bugzilla at libav.org
        ReportedBy: imprec at gmail.com


When using avconv with the transpose filter and an output frame size like this
: 

'/usr/local/bin/avconv' '-y' '-i' IMG_6162.MOV '-vf' 'transpose=1'
-metadata:s:v:0 rotate=0 -s 284x160  'transposed-resized.mov'

The output does not have the expected frame size.

However, it works correctly on version 0.9 but it's wrong on 0.8 branch.

It should work as documentation says :

<pre>
‘-s[:stream_specifier] size (input/output,per-stream)’
Set frame size.

As an input option, this is a shortcut for the ‘video_size’ private option,
recognized by some demuxers for which the frame size is either not stored in
the file or is configurable – e.g. raw video or video grabbers.

As an output option, this inserts the scale video filter to the end of the
corresponding filtergraph. Please use the scale filter directly to insert it at
the beginning or some other place.
</pre>

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list