[libav-bugs] [Bug 545] New: _sem_timedwait undefined symbol from jack_audio

bugzilla at libav.org bugzilla at libav.org
Thu Aug 1 02:17:08 CEST 2013


https://bugzilla.libav.org/show_bug.cgi?id=545

           Summary: _sem_timedwait undefined symbol from jack_audio
           Product: Libav
           Version: git HEAD
          Platform: X86
        OS/Version: Mac OS
            Status: NEW
          Severity: minor
          Priority: Normal
         Component: general
        AssignedTo: bugzilla at libav.org
        ReportedBy: vitto.giova at yahoo.it


Compiling without --disable-avdevice on OS X 10.6 produces this error

Undefined symbols:
  "_sem_timedwait", referenced from:
      _audio_read_packet in libavdevice.a(jack_audio.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
Undefined symbols:
  "_sem_timedwait", referenced from:
      _audio_read_packet in libavdevice.a(jack_audio.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [avprobe] Error 1
make: *** Waiting for unfinished jobs....
Undefined symbols:
  "_sem_timedwait", referenced from:
      _audio_read_packet in libavdevice.a(jack_audio.o)
ld: symbol(s) not found
collect2: ld returned 1 exit status
make: *** [avconv] Error 1
make: *** [avplay] Error 1

Possibly interesting read
http://stackoverflow.com/questions/641126/posix-semaphores-on-mac-os-x-sem-timedwait-alternative

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list