[libav-bugs] [Bug 429] QA notice from Gentoo's build system

bugzilla-daemon at aruru.libav.org bugzilla-daemon at aruru.libav.org
Sat Apr 13 22:23:27 CEST 2013


https://bugzilla.libav.org/show_bug.cgi?id=429

--- Comment #3 from Toralf Förster <toralf.foerster at gmx.de> 2013-04-13 22:23:27 CEST ---
FWIW media-video/libav-0.8.5 gives here today :

QA Notice: The following files contain runtime text relocations
 Text relocations force the dynamic linker to perform extra
 work at startup, waste system resources, and may pose a security
 risk.  On some architectures, the code may not even function
 properly, if at all.
 For more information, see http://hardened.gentoo.org/pic-fix-guide.xml
 Please include the following list of files in your report:
TEXTREL usr/lib/libavfilter.so.2.15.0
TEXTREL usr/lib/libswscale.so.2.1.0
TEXTREL usr/lib/libavformat.so.53.21.1
TEXTREL usr/lib/libavutil.so.51.22.1
TEXTREL usr/lib/libavcodec.so.53.35.0
TEXTREL usr/lib/libavdevice.so.53.2.0
QA Notice: Package triggers severe warnings which indicate that it
           may exhibit random runtime failures.
libswscale/x86/swscale_template.c:789:9: warning: dereferencing type-punned
pointer will break strict-aliasing rules [-Wstrict-aliasing]
libswscale/x86/swscale_template.c:790:9: warning: dereferencing type-punned
pointer will break strict-aliasing rules [-Wstrict-aliasing]
libswscale/x86/swscale_template.c:789:9: warning: dereferencing type-punned
pointer will break strict-aliasing rules [-Wstrict-aliasing]
libswscale/x86/swscale_template.c:790:9: warning: dereferencing type-punned
pointer will break strict-aliasing rules [-Wstrict-aliasing]
QA Notice: Package triggers severe warnings which indicate that it
           may exhibit random runtime failures.
libavcodec/h264.c:3826:31: warning: array subscript is below array bounds
[-Warray-bounds]
QA Notice: Package triggers severe warnings which indicate that it
           may exhibit random runtime failures.
libavcodec/adpcm.c:1172:20: warning: array subscript is above array bounds
[-Warray-bounds]
libavcodec/adpcm.c:1172:20: warning: array subscript is above array bounds
[-Warray-bounds]

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list