[libav-bugs] [Bug 325] New: problems with using -ss option when transcoding from *.vob to *.avi

Anton Khirnov anton at khirnov.net
Tue Jul 3 15:22:01 CEST 2012


On Mon,  2 Jul 2012 00:30:11 +0200 (CEST), bugzilla-daemon at aruru.libav.org wrote:
> https://bugzilla.libav.org/show_bug.cgi?id=325
> 
>            Summary: problems with using -ss option when transcoding from
>                     *.vob to *.avi
>            Product: Libav
>            Version: 0.8
>           Platform: X86
>         OS/Version: Linux
>             Status: NEW
>           Severity: normal
>           Priority: Normal
>          Component: utilities
>         AssignedTo: bugzilla at libav.org
>         ReportedBy: superandrzej at epf.pl
> 
> 
> I am trying to transcode from *.vob to *.avi.
> As long as I don't use -ss option everything works as expected.
> With -ss option avconv exits with following error:
> 
>  avconv -ss 0:17:47 -t 01:28:48.4 -i '/A/film.vob' -ac 2 '/A/film.avi'

Does it happen with all vobs or just one? Does changing the seek time
have any influence on it?

As a temporary workaround you can use -ss as an output option (move it
before the output filename), which will be slower (since avconv will
decode everything), but should work more reliably.

Also note that -t is strictly an output option, specifying it as an
input option has no effect (i hope to fix the options parser so it
prints an error in such a case soon).


-- 
Anton Khirnov


More information about the libav-bugs mailing list