[libav-bugs] [Bug 353] New: Build fails in libavcodec/motionpixels_tablegen.h

bugzilla-daemon at aruru.libav.org bugzilla-daemon at aruru.libav.org
Sat Aug 25 15:47:25 CEST 2012


https://bugzilla.libav.org/show_bug.cgi?id=353

           Summary: Build fails in libavcodec/motionpixels_tablegen.h
           Product: Libav
           Version: git HEAD
          Platform: X86
        OS/Version: Mac OS
            Status: NEW
          Severity: normal
          Priority: Normal
         Component: libavcodec
        AssignedTo: bugzilla at libav.org
        ReportedBy: werner.robitza at gmail.com


I'm trying to build libav from the latest Git HEAD on OS X 10.8.1 with Xcode
4.4.1.

I ran. as I usually do:

./configure --enable-gpl --enable-nonfree --enable-version3
--enable-hardcoded-tables  --enable-libx264 --enable-libfaac --enable-libtheora
--enable-libvo-aacenc --enable-libvorbis --enable-libvpx --enable-libmp3lame

Then "make", and the result was:

HOSTCC    libavcodec/motionpixels_tablegen.o
In file included from libavcodec/motionpixels_tablegen.c:27:
libavcodec/motionpixels_tablegen.h: In function 'mp_yuv_to_rgb':
libavcodec/motionpixels_tablegen.h:33: error: initializer element is not
computable at load time
make: *** [libavcodec/motionpixels_tablegen.o] Error 1

The project however builds fine when just running "./configure"

-- 
Configure bugmail: https://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are watching all bug changes.


More information about the libav-bugs mailing list