[libav-bugs] [Bug 20] New: AAC decoding error when channel map changed

bugzilla-daemon at batanen.kinali.ch bugzilla-daemon at batanen.kinali.ch
Fri Jul 22 19:49:44 CEST 2011


http://bugzilla.libav.org/show_bug.cgi?id=20

           Summary: AAC decoding error when channel map changed
           Product: Libav
           Version: 0.7
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: Normal
         Component: libavcodec
        AssignedTo: libav-bugs at libav.org
        ReportedBy: tsuchim-libav at sea-mew.jp


There are sample file and some logs,
ftp://sea-mew.jp/libav/mpegtssample.ts
(I'm sorry, but I cannot connect your upload ftp server)

ftp://sea-mew.jp/libav/mpegtssample.ts is sample file. MPEG2TS container with
mpeg2video and aac audio.
I want to transcoding to h.264 using libav 0.7.

command is, mpeg -i mpegtssample.ts -vcodec libx264 -vpre medium -b 1M -acodec
libfaac -aq 80 mpegtssample.mp4
this command is almost success against good input, but not for this.
The error log is, ftp://sea-mew.jp/libav/mpegtssample.log
I think audio profile was changed in the file, and decoder cannot follow the
change.

ffprobe results for pre- and post-gap for the file are
ftp://sea-mew.jp/libav/mpegtssample-part1.log and part2.log

Could you follow the changing of audio profile during MPEG2 stream?
Thank you in advance.

-- 
Configure bugmail: http://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the libav-bugs mailing list