[libav-bugs] [Bug 14] New: Remuxing video fails

bugzilla-daemon at batanen.kinali.ch bugzilla-daemon at batanen.kinali.ch
Thu Jul 14 04:16:13 CEST 2011


http://bugzilla.libav.org/show_bug.cgi?id=14

           Summary: Remuxing video fails
           Product: Libav
           Version: git HEAD
          Platform: PC
        OS/Version: Linux
            Status: NEW
          Severity: major
          Priority: Normal
         Component: utilities
        AssignedTo: libav-bugs at libav.org
        ReportedBy: igloo at earth.li


I was trying to remux http://urchin.earth.li/~ian/video_problem/00001.MTS (8
MB) but I get:

$ ffmpeg -i 00001.MTS -vcodec copy -acodec copy 00001.mp4
ffmpeg version v0.7-393-gac4a85f, Copyright (c) 2000-2011 the Libav developers
  built on Jul 14 2011 02:05:57 with gcc 4.6.1
  configuration: --prefix=/home/ian/code/libav/inst
  libavutil    51.  8. 0 / 51.  8. 0
  libavcodec   53.  5. 0 / 53.  5. 0
  libavformat  53.  2. 0 / 53.  2. 0
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  4. 0 /  2.  4. 0
  libswscale    2.  0. 0 /  2.  0. 0

Seems stream 0 codec frame rate differs from container frame rate: 50.00 (50/1)
-> 50.00 (50/1)
Input #0, mpegts, from '00001.MTS':
  Duration: 00:00:04.16, start: 1.000033, bitrate: 16038 kb/s
  Program 1 
    Stream #0.0[0x1011]: Video: h264 (High), yuv420p, 1920x1080 [PAR 1:1 DAR
16:9], 50 fps, 50 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x1100]: Audio: ac3, 48000 Hz, 5.1, s16, 448 kb/s
    Stream #0.2[0x1200]: Subtitle: pgssub
Output #0, mp4, to '00001.mp4':
  Metadata:
    encoder         : Lavf53.2.0
    Stream #0.0: Video: ![0][0][0] / 0x0021, yuv420p, 1920x1080 [PAR 1:1 DAR
16:9], q=2-31, 25 tbn, 25 tbc
    Stream #0.1: Audio: ac3, 48000 Hz, 5.1, 448 kb/s
Stream mapping:
  Stream #0.0 -> #0.0
  Stream #0.1 -> #0.1
Press ctrl-c to stop encoding
[mp4 @ 0x144d780] Application provided invalid, non monotonically increasing
dts to muxer in stream 0: 1 >= 1
av_interleaved_write_frame(): Invalid argument




More info:

$ ~/code/libav/inst/bin/ffmpeg -v 9 -loglevel 99 -i 00001.MTS          
ffmpeg version v0.7-393-gac4a85f, Copyright (c) 2000-2011 the Libav developers
  built on Jul 14 2011 02:05:57 with gcc 4.6.1
  configuration: --prefix=/home/ian/code/libav/inst
  libavutil    51.  8. 0 / 51.  8. 0
  libavcodec   53.  5. 0 / 53.  5. 0
  libavformat  53.  2. 0 / 53.  2. 0
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  4. 0 /  2.  4. 0
  libswscale    2.  0. 0 /  2.  0. 0
[mpegts @ 0x172d380] Probed with size=2048 and score=100
[mpegts @ 0x172d380] stream=0 stream_type=1b pid=1011 prog_reg_desc=HDMV
[mpegts @ 0x172d380] stream=1 stream_type=81 pid=1100 prog_reg_desc=HDMV
[mpegts @ 0x172d380] stream=2 stream_type=90 pid=1200 prog_reg_desc=HDMV
[h264 @ 0x1732920] Unsupported bit depth: 0
[h264 @ 0x1732920] no picture
[mpegts @ 0x172d380] Probe buffer size limit 5000000 reached

Seems stream 0 codec frame rate differs from container frame rate: 50.00 (50/1)
-> 50.00 (50/1)
Input #0, mpegts, from '00001.MTS':
  Duration: 00:00:04.16, start: 1.000033, bitrate: 16038 kb/s
  Program 1 
    Stream #0.0[0x1011], 137, 1/90000: Video: h264 (High), yuv420p, 1920x1080
[PAR 1:1 DAR 16:9], 1/50, 50 fps, 50 tbr, 90k tbn, 50 tbc
    Stream #0.1[0x1100], 76, 1/90000: Audio: ac3, 48000 Hz, 5.1, s16, 448 kb/s
    Stream #0.2[0x1200], 30, 1/90000: Subtitle: pgssub
At least one output file must be specified

-- 
Configure bugmail: http://bugzilla.libav.org/userprefs.cgi?tab=email
------- You are receiving this mail because: -------
You are the assignee for the bug.


More information about the libav-bugs mailing list