<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40"><head><META HTTP-EQUIV="Content-Type" CONTENT="text/html; charset=us-ascii"><meta name=Generator content="Microsoft Word 14 (filtered medium)"><style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]--></head><body lang=EN-US link=blue vlink=purple><div class=WordSection1><p class=MsoNormal>I work on a project that uses AVI files, primarily XVID.  I have written a library that parses the AVI files to make sure that they are intact and use a supported codec.  If the FourCC is "XVID", it parses into the stream to get the XVID bitstream version.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>This morning, I was shown an AVI file that has me a bit confused.  The AVI header identifies it as "xvid", but the stream data does not have the usual "XviD****" for the bitstream version.  Instead, it has "Lavc53.117.0".  There is also a JUNK chunk that says "Lavf52.105.0".<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>The system that was supposed to play it had problems with it until a newer version of XVID was installed on it.  After that, it plays it back just fine.<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>What kind of file is this?  Is it a misbaleled XVID file?  Or is it a valid XVID that uses some lesser-known encoding scheme?<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p><p class=MsoNormal>Jordon<o:p></o:p></p><p class=MsoNormal><o:p> </o:p></p></div></body></html>