Excellent, thanks! It wasn't obvious to me from the message that this was an encoder switch, but I guess that makes sense.<div><br></div><div>-Aaron.</div><div><br><br><div class="gmail_quote">On Fri, Nov 4, 2011 at 9:49 AM, Justin Ruggles <span dir="ltr"><<a href="mailto:justin.ruggles@gmail.com">justin.ruggles@gmail.com</a>></span> wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex;"><div class="im">On 11/04/2011 10:27 AM, Aaron San Filippo wrote:<br>
<br>
> Hey all, I'm trying to encode a video with audio in the .mp4 format,<br>
> using avconv from the commandline, using a recent win32 build.<br>
><br>
> I'm getting an error telling me that the 'aac' format is experimental<br>
> and that I should use '-strict experimental' if I want to use it.<br>
> However adding this switch doesn't fix the problem, at least with the<br>
> switches I'm using.<br>
><br>
> Is there a workaround for this - perhaps a different audio encoder I<br>
> can/should use with this format?<br>
><br>
> My complete command line:<br>
><br>
> avconv -strict experimental -i Audio.wav   -pix_fmt bgr24 -s 640x480 -f<br>
> rawvideo -r 25.5 -i RawMovie -vcodec libx264 -y -vf "vflip" movie.mp4<br>
<br>
</div>order matters. in this case you need to put -strict experimental on the<br>
output side, after your inputs.  it's the encoder that is experimental.<br>
<br>
-Justin<br>
_______________________________________________<br>
libav-api mailing list<br>
<a href="mailto:libav-api@libav.org">libav-api@libav.org</a><br>
<a href="https://lists.libav.org/mailman/listinfo/libav-api" target="_blank">https://lists.libav.org/mailman/listinfo/libav-api</a><br>
</blockquote></div><br></div>