Hey all, I'm trying to encode a video with audio in the .mp4 format, using avconv from the commandline, using a recent win32 build.<br><br>I'm getting an error telling me that the 'aac' format is experimental and that I should use '-strict experimental' if I want to use it.<div>
However adding this switch doesn't fix the problem, at least with the switches I'm using.<br><br>Is there a workaround for this - perhaps a different audio encoder I can/should use with this format?</div><div><br>
My complete command line:<br><br>avconv -strict experimental -i Audio.wav   -pix_fmt bgr24 -s 640x480 -f rawvideo -r 25.5 -i RawMovie -vcodec libx264 -y -vf "vflip" movie.mp4<br><br>And the complete output:<br><br>
<div>avconv version v0.7-1645-g0217099, Copyright (c) 2000-2011 the Libav developers</div><div>  built on Oct 31 2011 15:47:25 with gcc 4.5.2</div><div>[wav @ 003e9e20] max_analyze_duration reached</div><div>Input #0, wav, from 'Audio.wav':</div>
<div>  Duration: 00:00:35.88, bitrate: 705 kb/s</div><div>    Stream #0.0: Audio: pcm_s16le, 44100 Hz, 1 channels, s16, 705 kb/s</div><div>[rawvideo @ 00df0180] Estimating duration from bitrate, this may be inaccurate</div>
<div>Input #1, rawvideo, from 'RawMovie':</div><div>  Duration: N/A, start: 0.000000, bitrate: N/A</div><div>    Stream #1.0: Video: rawvideo, bgr24, 640x480, 25.50 tbr, 25.50 tbn, 25.50 tb</div><div>c</div><div>Incompatible pixel format 'bgr24' for codec 'libx264', auto-selecting format 'yu</div>
<div>v420p'</div><div>[buffer @ 00dd9a60] w:640 h:480 pixfmt:bgr24</div><div>[vflip @ 00dfea60] auto-inserting filter 'auto-inserted scaler 0' between the fi</div><div>lter 'src' and the filter 'Parsed filter 0 vflip'</div>
<div>[scale @ 00e30da0] w:640 h:480 fmt:bgr24 -> w:640 h:480 fmt:yuv420p flags:0x4</div><div>[libx264 @ 00e06280] using cpu capabilities: MMX2 SSE2Fast SSSE3 FastShuffle SSE</div><div>4.1 Cache64</div><div>[libx264 @ 00e06280] profile Main, level 3.0</div>
<div>[libx264 @ 00e06280] 264 - core 118 - H.264/MPEG-4 AVC codec - Copyleft 2003-201</div><div>1 - <a href="http://www.videolan.org/x264.html">http://www.videolan.org/x264.html</a> - options: cabac=1 ref=3 deblock=1:0:0 ana</div>
<div>lyse=0x1:0x111 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=0 me_range=16 chr</div><div>oma_me=1 trellis=1 8x8dct=0 cqm=0 deadzone=21,11 fast_pskip=1 chroma_qp_offset=-</div><div>2 threads=3 sliced_threads=0 nr=0 decimate=1 interlaced=0 bluray_compat=0 constr</div>
<div>ained_intra=0 bframes=3 b_pyramid=0 b_adapt=1 b_bias=0 direct=1 weightb=0 open_g</div><div>op=1 weightp=2 keyint=250 keyint_min=25 scenecut=40 intra_refresh=0 rc_lookahead</div><div>=40 rc=crf mbtree=1 crf=23.0 qcomp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.25</div>
<div>aq=1:1.00</div><div>encoder 'aac' is experimental and might produce bad results.</div><div>Add '-strict experimental' if you want to use it.</div><br></div>