[libav-api] Symbol conflict with FFmpeg

Luca Barbato lu_zero at gentoo.org
Fri Apr 17 22:26:55 CEST 2015


On 17/04/15 04:59, Jing huang wrote:
> Hi there,
> 
> I am facing an issue while trying to integrated two open sourced libraries
> together, one is gstreamer which is using libav from libav.org, another is
> kickflip which uses libav from ffmpeg. The issue is both libraries has the
> same named libavcodec.a and other libavxxx.a static library included in
> their package. I have been trying to solve the conflict by finding a
> matching version of libav from libav.org and ffmpeg, it seems impossible
> with the latest version of this two diverged library.

You would have the same problem while using binaries from different
versions as well. I'm not sure where the kickflip code is so I can't
even check and see how it could be compiled with our offering.


lu


More information about the libav-api mailing list