[libav-api] Cannot open stream

Joshua Kordani jkordani at lsa2.com
Wed Jun 11 19:34:57 CEST 2014


and alternatively, what happens when you point your code at the 
following rtsp url?
rtsp://184.72.239.149/vod/mp4:BigBuckBunny_115k.mov

Joshua Kordani
LSA Autonomy

On 6/11/14 11:49 AM, Manuel Torres wrote:
> Done. I captured just a few seconds to keep the file size low. Here is the
> download link:
>
> https://www.wetransfer.com/downloads/8d6c64606d347f395c6a0dfd8702419b20140611154702/5f67e064c7ebf8c694577589d69c1d5420140611154702/c7dee4
>
>
> On Wed, Jun 11, 2014 at 5:32 PM, Joshua Kordani <jkordani at lsa2.com> wrote:
>
>> Can you make a short wireshark capture that includes the rtsp as well as
>> the rtp traffic going from this camera, for, say, 30 seconds?  Do this
>> using your program to start the feed.
>>
>> Joshua Kordani
>> LSA Autonomy
>>
>>
>> On 6/11/14 11:21 AM, Manuel Torres wrote:
>>
>>> No. It is an external source of which I have no control and I cannot
>>> figure
>>> out what is diferent in it from the rest if the sources I can open with
>>> both avplay and my code. It puzzles me even more that VLC and MPlayer do
>>> open the stream.
>>>
>>> Enviado desde dispositivo móvil.
>>> Sent from mobile device.
>>> On Jun 11, 2014 5:15 PM, "Joshua Kordani" <jkordani at lsa2.com> wrote:
>>>
>>>   Are you creating this stream yourself?
>>>> Joshua Kordani
>>>> LSA Autonomy
>>>>
>>>> On 6/11/14 11:08 AM, Manuel Torres wrote:
>>>>
>>>>   If by "resource" you mean the URL, the answer is no, avplay does not
>>>>> display the video. The traces in my first e-mail are also displayed by
>>>>> avplay, that is, no size and no color space.
>>>>>
>>>>> Enviado desde dispositivo móvil.
>>>>> Sent from mobile device.
>>>>> On Jun 11, 2014 4:10 PM, "Luca Barbato" <lu_zero at gentoo.org> wrote:
>>>>>
>>>>>    On 11/06/14 09:41, Manuel Torres wrote:
>>>>>
>>>>>> First of all, thank you Luca and Joshua for taking the time to help me
>>>>>>>   and
>>>>>>   thank you very much Joshua for that awesome explanation. I see that
>>>>>>> there
>>>>>>> is a lot to learn.
>>>>>>>
>>>>>>> Back on topic:
>>>>>>> I checked the format context and the codec context and I only found an
>>>>>>> empty (NULL) "extradata" field in the codec context. I also checked
>>>>>>> some
>>>>>>> other fields in both structures where I thought the data could be but
>>>>>>>
>>>>>>>   found
>>>>>>   nothing. Am I looking in the right place?
>>>>>>>    Looks quite strange, if you just do avplay rtsp://resource
>>>>>>>
>>>>>> does it play?
>>>>>>
>>>>>> lu
>>>>>>
>>>>>> _______________________________________________
>>>>>> libav-api mailing list
>>>>>> libav-api at libav.org
>>>>>> https://lists.libav.org/mailman/listinfo/libav-api
>>>>>>
>>>>>>    _______________________________________________
>>>>>>
>>>>> libav-api mailing list
>>>>> libav-api at libav.org
>>>>> https://lists.libav.org/mailman/listinfo/libav-api
>>>>>
>>>>>   _______________________________________________
>>>> libav-api mailing list
>>>> libav-api at libav.org
>>>> https://lists.libav.org/mailman/listinfo/libav-api
>>>>
>>> _______________________________________________
>>> libav-api mailing list
>>> libav-api at libav.org
>>> https://lists.libav.org/mailman/listinfo/libav-api
>>>
>> _______________________________________________
>> libav-api mailing list
>> libav-api at libav.org
>> https://lists.libav.org/mailman/listinfo/libav-api
>>
> _______________________________________________
> libav-api mailing list
> libav-api at libav.org
> https://lists.libav.org/mailman/listinfo/libav-api



More information about the libav-api mailing list