[libav-api] Cannot open stream

Joshua Kordani jkordani at lsa2.com
Wed Jun 11 17:15:13 CEST 2014


Are you creating this stream yourself?

Joshua Kordani
LSA Autonomy

On 6/11/14 11:08 AM, Manuel Torres wrote:
> If by "resource" you mean the URL, the answer is no, avplay does not
> display the video. The traces in my first e-mail are also displayed by
> avplay, that is, no size and no color space.
>
> Enviado desde dispositivo móvil.
> Sent from mobile device.
> On Jun 11, 2014 4:10 PM, "Luca Barbato" <lu_zero at gentoo.org> wrote:
>
>> On 11/06/14 09:41, Manuel Torres wrote:
>>> First of all, thank you Luca and Joshua for taking the time to help me
>> and
>>> thank you very much Joshua for that awesome explanation. I see that there
>>> is a lot to learn.
>>>
>>> Back on topic:
>>> I checked the format context and the codec context and I only found an
>>> empty (NULL) "extradata" field in the codec context. I also checked some
>>> other fields in both structures where I thought the data could be but
>> found
>>> nothing. Am I looking in the right place?
>>>
>> Looks quite strange, if you just do avplay rtsp://resource
>>
>> does it play?
>>
>> lu
>>
>> _______________________________________________
>> libav-api mailing list
>> libav-api at libav.org
>> https://lists.libav.org/mailman/listinfo/libav-api
>>
> _______________________________________________
> libav-api mailing list
> libav-api at libav.org
> https://lists.libav.org/mailman/listinfo/libav-api



More information about the libav-api mailing list